Welcome Guest! To enable all features please Login or Register.



Automatic ADIF not working using UNC
#1 Posted : Thursday, November 25, 2021 6:48:44 AM(UTC)
Rank: Newbie

Groups: Registered
Posts: 1
Location: Ireland

I am helping a friend move his Logic to macOS running Windows/Parallels. It works very well, and so does all of his other amateur radio software. I have set-up the Log/Setup automatic ADIF import for WSJT-X but there is a problem. WSJT-X adif file location is not on the Windows drive but on the VM’s macOS host. It is visible to Logic via a UNC file name \\Mac\Users\dave\Library\Application Support\WSJT-X\wsjtx_log.adi. The problem is that Logic does not notice when that file changes when WSJT-X writes to it. I have tried faking the update by copying over that file, but that immediately crashes Logic. I suspect Logic has a file handle open for reading and does not like the copy.

Is there any other way I could “ping” Logic that the file has changed? Any other suggestions how to make Logic import from WSJT-X?

Many thanks.
73 Rafal EI6LA
Note: We receive a commission from Amazon when you purchase via this link. It does not affect your cost. Thank you!
#2 Posted : Friday, November 26, 2021 4:34:55 PM(UTC)

Rank: Administration

Groups: Administrators, Beta Testers
Posts: 3,061
Location: Auburn, GA

Thanks: 974 times
Was thanked: 485 time(s) in 400 post(s)

LOGic does not poll or monitor the WSJT-X ADIF file in any way. It uses Windows FilsSystemWatcher, which notifies LOGic any time a change is made to the file. Read the .NET documentation on System.IO.FilesystemWatcher of you want details.

I tried it using a UNC over a Windows network and it works no problem. I searched the web and could not find anything saying it isn't supported on IOS.

Send me the error message that you get when you overwrite the file. That could be a clue. You can delete the WSJT-X ADIF file. WSJT-X will create a new one the next time it logs a QSO, and LOGic is none the wiser. You would think that overwriting would be the same thing, but try deleting the existing file first. LOGic doesn't keep the file open. When it gets a notification that the file has changed, it opens it in shared read-only mode, reads the new bit off the end, and promptly closes it.

I would try updating everything -- Parallels, Windows, network drivers, or whatever. Perhaps using the term FileSystemWatcher on a Parallels or Mac forum may turn up someone who can help.

I have attached a simple utility to test FileSystemWatcher. Put it in c:\program files (x86)\logic\assembly Double-click to run.

If we can't get your system to fire FileSystemWatcher, you can always import the ADIF file as from tools/import. LOGic users have been doing that for years. But that is a pain. It would be worth some effort to try to figure out what is going on.

Here is an idea for a workaround. Can't you tell WSJT-X to put its ADIF file across the network on the Windows side of things?

Let me know what you find.

Tnx & 73,

Dennis WN4AZY
File Attachment(s):
FileSystemWatcher.exe (14kb) downloaded 27 time(s).
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2011, Yet Another Forum.NET
This page was generated in 0.025 seconds.