logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Erratic Freq display and control
n8gls
#1 Posted : Thursday, September 13, 2018 10:08:52 AM(UTC)
bwilliams

Rank: Advanced Member

Groups: Registered
Posts: 226
Location: Mentor, OH

Thanks: 45 times
Was thanked: 41 time(s) in 37 post(s)
Just today when changing frequency on my rig from the rig control window the freq will suddenly be off from what the rig is displaying. When tuning from the rig it tracks perfectly but when tuning from the rig control window it jumps and doesn't track to the rig. Its not consistent, and mostly tracks but then suddenly doesn't. I suspected a fault with my rig or my interface but I have three rigs and all have their own interface and all have this issue so don't think it has anything to do with them. Again its only when tuning from LOGic, if from the rig all is fine. Anyone else seeing this issue ?? There was a windows 10 update yesterday and so I fear it may be associated with that. I'll try to capture the data stream and post it later.

PS: All rigs are Icom, all FTDI, no changes recently, all were working fine. Windows 10, LOGic v.9.1.37.
IC-735 using driver #47, IC-746Pro #56, IC-756ProII #48

Just tried the legacy driver #18 with the IC-735 and that driver works fine. I'll try the legacy drivers for the other Icoms later and report back.

PS: Note that I'm changing frequency within LOGic via the mouse wheel. No recent driver or hardware changes.

Thanks,

73 de Brad
Sponsor
Note: We receive a commission from Amazon when you purchase via this link. It does not affect your cost. Thank you!
w2zi
#2 Posted : Friday, September 14, 2018 5:19:59 PM(UTC)
Rank: Advanced Member

Groups: Registered
Posts: 119
Man
Location: Daytona Beach

Thanks: 25 times
Was thanked: 40 time(s) in 38 post(s)
Try downloading 9.1.37 again. Dennis tweaked it for a slight problem I was having with the OmniRig interface. It also turned out to fix a bug that I had not yet reported that first showed up with 9.1.37. Worth a try.

73s, Don
2 users thanked w2zi for this useful post.
WN4AZY on 9/15/2018(UTC), n8gls on 9/16/2018(UTC)
WN4AZY
#3 Posted : Saturday, September 15, 2018 9:45:47 PM(UTC)
admin

Rank: Administration

Groups: Administrators, Beta Testers
Posts: 2,282
Man
Location: Auburn, GA

Thanks: 456 times
Was thanked: 308 time(s) in 244 post(s)
Hi Brad:

Not sure what's going on. A reinstall of 9.1.37 may fix something. And a reboot. As W2ZI discovered, I did fix Omnirig. But no other changes.

Does it work ok when you set the freq from the spot log or the log form?

Yeah, looking at the com port log is the next step.

Tnx & 73,

Dennis WN4AZY
1 user thanked WN4AZY for this useful post.
n8gls on 9/16/2018(UTC)
n8gls
#4 Posted : Sunday, September 16, 2018 10:29:41 PM(UTC)
bwilliams

Rank: Advanced Member

Groups: Registered
Posts: 226
Location: Mentor, OH

Thanks: 45 times
Was thanked: 41 time(s) in 37 post(s)
Thanks Don/Dennis,

I re-installed v9.1.37 the same day the anomalies occured and again just a few minutes ago just to be sure i got the latest. Also re-booted afterwards and no change. Setting the rig(s) from the spot log works, well, it worked for Rig 2 (IC-746Pro), and Rig 1 (IC-756ProII), but for Rig 3 (IC-735) for a spotted frequency of 7.128 Mhz, setting the rig resulted in the rig displaying 7.21-.C instead of 7.218.0, weird. So on the 735 it messes up the rig display frequency. You can see it in real time swapping a - or a C for a digit.

On the 746Pro and 756ProII if changing frequency with the mouse wheel the rig display tracks for a few Mhz but then gets off track. Say on 2m, 144.200 using the mouse wheel and tuning down to 144.175, the rig window in LOGic displays correctly but the rig's display say at 144.180 in LOGic suddenly jumps to 144.200 on the rig's display, eventually after some more tuning they re-track but get out of track if I keep tuning. Same with the 756ProII. The 735's display just gets screwy with a character "-" or a "C" in place of a digit. After mouse wheel tuning the 735 in LOGic and having it go through several of the odd characters being displayed it right now is displaying 7.201.4 and LOGic shows 7.209.7 Mhz.

When I say that LOGic's rig control window is displaying correctly I mean that while mouse wheel tuning up or down in frequency it increments correctly. The rigs display however at some point while tuning gets off track and jumps by anywhere from about 100 Hz up to several Khz.

I havent played with the number of stop bits but maybe will change those and see if that makes a difference. I probably should look at the driver for my 7-Port USB board. The FTDI drivers maybe I should go look at as well. I think there was a driver update not too long ago and heck, it may have happened then....too many variables here for sure and will have to root them out.

PS: Attached Com Port Data as a text file as it was too big to post. This was for Rig 2, IC-746PRO, mouse tuned from LOGic, and it lost tracking.

Thanks All,

de Brad
File Attachment(s):
COM4_Log.txt (31kb) downloaded 3 time(s).
WN4AZY
#5 Posted : Monday, September 17, 2018 9:21:40 PM(UTC)
admin

Rank: Administration

Groups: Administrators, Beta Testers
Posts: 2,282
Man
Location: Auburn, GA

Thanks: 456 times
Was thanked: 308 time(s) in 244 post(s)
Quote:
The 735's display just gets screwy with a character "-" or a "C" in place of a digit.
Do you mean the display in LOGic, or the display on the 735?

Try turning off Overlapped IO in LOGic.
n8gls
#6 Posted : Monday, September 17, 2018 10:07:36 PM(UTC)
bwilliams

Rank: Advanced Member

Groups: Registered
Posts: 226
Location: Mentor, OH

Thanks: 45 times
Was thanked: 41 time(s) in 37 post(s)
The display on the 735.

LOGics display seems fine, incrementing as it should. The 735 display gets off track, then if I tune some more it gets back on track. Last night I did have the display on the 735 lock up, it froze after displaying the odd characters. Changing the VFO from A to B in LOGic brought it back and it was tracking again until the display on the 735 showed the odd characters again. Tonight tried all three rigs with OL off and no difference. I was going to try another mouse but after setting the 735 from the spot log last night resulting in the 735 display being off track I don't think its the mouse. Think I'll shut off the 756 and the 735 and play with just the 746Pro and see if I notice any pattern to this as well as looking at the USB board and maybe re-installing the driver, also the FTDI drivers.

Did anything look funny in the data stream on the 746Pro ??

Thanks, de Brad
n8gls
#7 Posted : Saturday, September 22, 2018 9:54:56 AM(UTC)
bwilliams

Rank: Advanced Member

Groups: Registered
Posts: 226
Location: Mentor, OH

Thanks: 45 times
Was thanked: 41 time(s) in 37 post(s)
Today tried to set rig from the spot log and experienced the following:

Rig at 18.125, set rig to 7.260 from spot log, that worked fine, then set rig from spot log back to 18.125, the rig went to 18.125 then jumped back to 7.260 then jumped to 18.125 in rapid succession. Com port data below.


18-09-22 10:27:36.35 LogComment
18-09-22 10:27:36.35 LogComment ------------------------------------------------------------------------------
18-09-22 10:27:36.35 LogComment LOGic Version: 9.1.37
18-09-22 10:27:36.35 LogComment Class: icom
18-09-22 10:27:36.35 LogComment Modlue: rigifc9.vcx
18-09-22 10:27:36.35 LogComment Descr: Icom -- rigs that have Split control
18-09-22 10:27:36.35 LogComment Notes: For icom rigs that permit computer control of split. Modes USB, LSB, CW, AM, FM. IC-725, 726, 238, 729, 765, 970
18-09-22 10:27:36.35 LogComment Ifc#: 47
18-09-22 10:27:36.35 LogComment Poll: May poll
18-09-22 10:27:36.35 LogComment Poll interval: Not polling
18-09-22 10:27:36.35 LogComment Port: COM8
18-09-22 10:27:36.35 LogComment Baud: 1200
18-09-22 10:27:36.35 LogComment Stop Bits: 2
18-09-22 10:27:36.35 LogComment DTR: False
18-09-22 10:27:36.35 LogComment RTS: False
18-09-22 10:27:36.35 LogComment Overlapped: True
18-09-22 10:27:36.56 LogComment Mfgr: FTDI
18-09-22 10:27:36.56 LogComment Device ID: FTDIBUS\VID_0403+PID_6001+AH061EQPA\0000
18-09-22 10:27:36.57 rx DiscardInBuffer
18-09-22 10:27:36.57 Write þþàý
18-09-22 10:27:36.57 tx WriteBinary FE FE 04 E0 04 FD
18-09-22 10:27:36.64 rx ReadToBinary FD FE FE 04 E0 04 FD
18-09-22 10:27:36.73 rx ReadToBinary FD FE FE E0 04 04 01 FD
18-09-22 10:27:36.73 rx DiscardInBuffer
18-09-22 10:27:36.73 Write þþà ý
18-09-22 10:27:36.73 tx WriteBinary FE FE 04 E0 0F 00 FD
18-09-22 10:27:36.81 rx ReadToBinary FD FE FE 04 E0 0F 00 FD
18-09-22 10:27:36.89 rx ReadToBinary FD FE FE E0 04 FA FD
18-09-22 10:27:36.89 rx DiscardInBuffer
18-09-22 10:27:36.89 Write þþàý
18-09-22 10:27:36.89 tx WriteBinary FE FE 04 E0 03 FD
18-09-22 10:27:36.96 rx ReadToBinary FD FE FE 04 E0 03 FD
18-09-22 10:27:37.09 rx ReadToBinary FD FE FE E0 04 03 00 50 12 18 FD
18-09-22 10:27:37.09 LogComment RThreshold set to 1. It was 0
18-09-22 10:27:37.09 LogComment RThreshold set to 0. It was 1
18-09-22 10:27:37.09 rx DiscardInBuffer
18-09-22 10:27:37.09 Write þþàý
18-09-22 10:27:37.09 tx WriteBinary FE FE 04 E0 03 FD
18-09-22 10:27:37.15 rx ReadToBinary FD FE FE 04 E0 03 FD
18-09-22 10:27:37.28 rx ReadToBinary FD FE FE E0 04 03 00 50 12 18 FD
18-09-22 10:27:37.28 LogComment RThreshold set to 1. It was 0
18-09-22 10:27:37.28 LogComment RThreshold set to 0. It was 1
18-09-22 10:27:37.28 rx DiscardInBuffer
18-09-22 10:27:37.28 Write þþàý
18-09-22 10:27:37.28 tx WriteBinary FE FE 04 E0 04 FD
18-09-22 10:27:37.34 rx ReadToBinary FD FE FE 04 E0 04 FD
18-09-22 10:27:37.44 rx ReadToBinary FD FE FE E0 04 04 01 FD
18-09-22 10:27:37.44 LogComment RThreshold set to 1. It was 0
18-09-22 10:27:37.44 LogComment RThreshold set to 0. It was 1
18-09-22 10:27:37.44 rx DiscardInBuffer
18-09-22 10:27:37.44 Write þþàý
18-09-22 10:27:37.44 tx WriteBinary FE FE 04 E0 03 FD
18-09-22 10:27:37.50 rx ReadToBinary FD FE FE 04 E0 03 FD
18-09-22 10:27:37.63 rx ReadToBinary FD FE FE E0 04 03 00 50 12 18 FD
18-09-22 10:27:37.63 LogComment RThreshold set to 1. It was 0
18-09-22 10:27:37.63 LogComment RThreshold set to 0. It was 1
18-09-22 10:27:37.63 rx DiscardInBuffer
18-09-22 10:27:37.63 Write þþàý
18-09-22 10:27:37.63 tx WriteBinary FE FE 04 E0 04 FD
18-09-22 10:27:37.69 rx ReadToBinary FD FE FE 04 E0 04 FD
18-09-22 10:27:37.79 rx ReadToBinary FD FE FE E0 04 04 01 FD
18-09-22 10:27:37.79 LogComment RThreshold set to 1. It was 0

18-09-22 10:28:21.99 LogComment RThreshold set to 0. It was 1
18-09-22 10:28:21.99 rx DiscardInBuffer
18-09-22 10:28:21.99 Write þþàý
18-09-22 10:28:21.99 tx WriteBinary FE FE 04 E0 03 FD
18-09-22 10:28:22.07 rx ReadToBinary FD FE FE 04 E0 03 FD
18-09-22 10:28:22.20 rx ReadToBinary FD FE FE E0 04 03 00 50 12 18 FD
18-09-22 10:28:22.20 LogComment RThreshold set to 1. It was 0
18-09-22 10:28:22.20 LogComment RThreshold set to 0. It was 1
18-09-22 10:28:22.20 rx DiscardInBuffer
18-09-22 10:28:22.20 Write þþàý
18-09-22 10:28:22.20 tx WriteBinary FE FE 04 E0 04 FD
18-09-22 10:28:22.26 rx ReadToBinary FD FE FE 04 E0 04 FD
18-09-22 10:28:22.35 rx ReadToBinary FD FE FE E0 04 04 01 FD
18-09-22 10:28:22.35 LogComment RThreshold set to 1. It was 0
18-09-22 10:28:22.46 LogComment RThreshold set to 0. It was 1
18-09-22 10:28:22.46 rx DiscardInBuffer
18-09-22 10:28:22.46 Write þþà ý
18-09-22 10:28:22.46 tx WriteBinary FE FE 04 E0 06 00 FD
18-09-22 10:28:22.53 rx ReadToBinary FD FE FE 04 E0 06 00 FD
18-09-22 10:28:22.63 rx ReadToBinary FD FE FE E0 04 FB FD
18-09-22 10:28:22.63 LogComment RThreshold set to 1. It was 0
18-09-22 10:28:22.63 LogComment RThreshold set to 0. It was 1
18-09-22 10:28:22.63 rx DiscardInBuffer
18-09-22 10:28:22.63 Write þþà &ý
18-09-22 10:28:22.63 tx WriteBinary FE FE 04 E0 05 00 00 26 07 FD
18-09-22 10:28:22.72 rx ReadToBinary FD FE FE 04 E0 05 00 00 26 07 FD
18-09-22 10:28:22.82 rx ReadToBinary FD FE FE E0 04 FB FD
18-09-22 10:28:22.82 LogComment RThreshold set to 1. It was 0

18-09-22 10:28:43.08 LogComment RThreshold set to 0. It was 1
18-09-22 10:28:43.08 rx DiscardInBuffer
18-09-22 10:28:43.08 Write þþàý
18-09-22 10:28:43.08 tx WriteBinary FE FE 04 E0 03 FD
18-09-22 10:28:43.14 rx ReadToBinary FD FE FE 04 E0 03 FD
18-09-22 10:28:43.27 rx ReadToBinary FD FE FE E0 04 03 00 00 26 07 FD
18-09-22 10:28:43.27 LogComment RThreshold set to 1. It was 0
18-09-22 10:28:43.27 LogComment RThreshold set to 0. It was 1
18-09-22 10:28:43.27 rx DiscardInBuffer
18-09-22 10:28:43.27 Write þþàý
18-09-22 10:28:43.27 tx WriteBinary FE FE 04 E0 04 FD
18-09-22 10:28:43.34 rx ReadToBinary FD FE FE 04 E0 04 FD
18-09-22 10:28:43.43 rx ReadToBinary FD FE FE E0 04 04 00 FD
18-09-22 10:28:43.43 LogComment RThreshold set to 1. It was 0
18-09-22 10:28:43.55 LogComment RThreshold set to 0. It was 1
18-09-22 10:28:43.55 rx DiscardInBuffer
18-09-22 10:28:43.55 Write þþàý
18-09-22 10:28:43.55 tx WriteBinary FE FE 04 E0 06 01 FD
18-09-22 10:28:43.62 rx ReadToBinary FD FE FE 04 E0 06 01 FD
18-09-22 10:28:43.72 rx ReadToBinary FD FE FE E0 04 FB FD
18-09-22 10:28:43.72 LogComment RThreshold set to 1. It was 0
18-09-22 10:28:43.72 LogComment RThreshold set to 0. It was 1
18-09-22 10:28:43.72 rx DiscardInBuffer
18-09-22 10:28:43.72 Write þþàý
18-09-22 10:28:43.72 tx WriteBinary FE FE 04 E0 07 01 FD
18-09-22 10:28:43.80 rx ReadToBinary FD FE FE 04 E0 07 01 FD
18-09-22 10:28:43.88 rx ReadToBinary FD FE FE E0 04 FB FD
18-09-22 10:28:43.88 LogComment RThreshold set to 1. It was 0
18-09-22 10:28:43.88 LogComment RThreshold set to 0. It was 1
18-09-22 10:28:43.88 rx DiscardInBuffer
18-09-22 10:28:43.88 Write þþàý
18-09-22 10:28:43.88 tx WriteBinary FE FE 04 E0 06 01 FD
18-09-22 10:28:43.96 rx ReadToBinary FD FE FE 04 E0 06 01 FD
18-09-22 10:28:44.04 rx ReadToBinary FD FE FE E0 04 FB FD
18-09-22 10:28:44.04 LogComment RThreshold set to 1. It was 0
18-09-22 10:28:44.04 LogComment RThreshold set to 0. It was 1
18-09-22 10:28:44.04 rx DiscardInBuffer
18-09-22 10:28:44.04 Write þþà ý
18-09-22 10:28:44.04 tx WriteBinary FE FE 04 E0 05 00 00 13 18 FD
18-09-22 10:28:44.13 rx ReadToBinary FD FE FE 04 E0 05 00 00 13 18 FD
18-09-22 10:28:44.23 rx ReadToBinary FD FE FE E0 04 FB FD
18-09-22 10:28:44.23 LogComment RThreshold set to 1. It was 0
18-09-22 10:28:44.23 LogComment RThreshold set to 0. It was 1
18-09-22 10:28:44.23 rx DiscardInBuffer
18-09-22 10:28:44.23 Write þþà ý
18-09-22 10:28:44.23 tx WriteBinary FE FE 04 E0 07 00 FD
18-09-22 10:28:44.31 rx ReadToBinary FD FE FE 04 E0 07 00 FD
18-09-22 10:28:44.39 rx ReadToBinary FD FE FE E0 04 FB FD
18-09-22 10:28:44.39 LogComment RThreshold set to 1. It was 0
18-09-22 10:28:44.39 LogComment RThreshold set to 0. It was 1
18-09-22 10:28:44.39 rx DiscardInBuffer
18-09-22 10:28:44.39 Write þþàý
18-09-22 10:28:44.39 tx WriteBinary FE FE 04 E0 03 FD
18-09-22 10:28:44.45 rx ReadToBinary FD FE FE 04 E0 03 FD
18-09-22 10:28:44.58 rx ReadToBinary FD FE FE E0 04 03 00 00 26 07 FD
18-09-22 10:28:44.58 LogComment RThreshold set to 1. It was 0
18-09-22 10:28:44.58 LogComment RThreshold set to 0. It was 1
18-09-22 10:28:44.58 rx DiscardInBuffer
18-09-22 10:28:44.58 Write þþàý
18-09-22 10:28:44.58 tx WriteBinary FE FE 04 E0 04 FD
18-09-22 10:28:44.65 rx ReadToBinary FD FE FE 04 E0 04 FD
18-09-22 10:28:44.74 rx ReadToBinary FD FE FE E0 04 04 01 FD
18-09-22 10:28:44.74 LogComment RThreshold set to 1. It was 0
18-09-22 10:28:44.74 LogComment RThreshold set to 0. It was 1
18-09-22 10:28:44.74 rx DiscardInBuffer
18-09-22 10:28:44.74 Write þþà Pý
18-09-22 10:28:44.74 tx WriteBinary FE FE 04 E0 05 00 50 12 18 FD
18-09-22 10:28:44.84 rx ReadToBinary FD FE FE 04 E0 05 00 50 12 18 FD
18-09-22 10:28:44.93 rx ReadToBinary FD FE FE E0 04 FB FD
18-09-22 10:28:44.93 LogComment RThreshold set to 1. It was 0
18-09-22 10:28:44.94 LogComment RThreshold set to 0. It was 1
18-09-22 10:28:44.94 rx DiscardInBuffer
18-09-22 10:28:44.94 Write þþàý
18-09-22 10:28:44.94 tx WriteBinary FE FE 04 E0 0F 01 FD
18-09-22 10:28:45.01 rx ReadToBinary FD FE FE 04 E0 0F 01 FD
18-09-22 10:28:45.11 rx ReadToBinary FD FE FE E0 04 FA FD

18-09-22 10:28:57.46 LogComment Disposing
1 user thanked n8gls for this useful post.
WN4AZY on 9/23/2018(UTC)
n8gls
#8 Posted : Sunday, October 14, 2018 11:40:21 PM(UTC)
bwilliams

Rank: Advanced Member

Groups: Registered
Posts: 226
Location: Mentor, OH

Thanks: 45 times
Was thanked: 41 time(s) in 37 post(s)
Dennis,

Saw your post on the 7610 fix and just for giggles I re-downloaded 9.1.37 and it seems whatever you did also fixed the erratic display issues for all three of the Icom rigs I have. The 735 still was experiencing a rapid double frequency change when using set rig from the spot log but I turned off OL and that seems to have resolved it, or at worst maybe its more random. I'll have to do a bunch of band changes via set rig from the spot log but the few I did after turning OL off seems to be fine now. More importantly the erratic tracking has gone away and no more weird characters are being displayed on the 735 either..

Just in time for CQWW in a couple weeks and I can drive the rigs from the mouse wheel again....NICE !

Thanks much for whatever you did !!

73 de Brad, N8GLS
Users browsing this topic
Guest (3)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF 1.9.5.5 | YAF © 2003-2011, Yet Another Forum.NET
This page was generated in 0.177 seconds.